Dart - 시작하기 - VSCode 설치

2020. 5. 18. 13:39난장 Dev/Flutter - Dart


먼저, Flutter를 시작하기 위해서 Dart라는 언어에 대해 공부가 필요하다.

나처럼 그냥 바로 Flutter를 시작할 수 있지만 얼마 후

나처럼 Dart를 시작할 것이다.

 

어렵지는 않지만

최소한 변수, 조건문, 반복문, 함수...... 등등등은 알아야 시작할 수 있지 않을까?

 

일단 그래서 다시 거꾸로

Flutter를 시작하기 전 상태로 Dart부터 좀 해보고 시작해보련다.

 

참고로 Dart 언어만을 가지고 테스트 하고자 한다면,  초기에 설치한 Android Studio에서는 Dart 언어만을 위한 프로젝트 생성이 안되므로 IntelliJVisual Studio Code(VSCode) 를 사용해 보는게 좋을 듯 하다.

 

나는 Mac에서 Visual Studio Code를 설치하고 테스트하고자 한다.

 

 

 

1. VSCode 설치하기

 

VSCode: https://code.visualstudio.com/

 

Visual Studio Code - Code Editing. Redefined

Visual Studio Code is a code editor redefined and optimized for building and debugging modern web and cloud applications.  Visual Studio Code is free and available on your favorite platform - Linux, macOS, and Windows.

code.visualstudio.com

 

위의 링크로 들아가보면 다운로드를 버튼이 떡하니 보인다.

클릭하면, 바로 Getting Started 페이지가 보이고 다운로드가 시작된다.

 

VSCode-darwin-satable.zip 파일이 다운로드되고 더블 클릭하면 Mac에서 사용가능한 응용프로그램이 나온다.

응용프로그램을 자신의 맥의 응용 프로그램으로 이동하고

실행시켜 보자.

 

위 화면까지 나오면 VSCode 설치는 끝.

 

 


  

 

 

2. Dart 설치

Extensions에 들어가서 Dart를 검색하고 설치(install) 한다.

 

설치는 금방되고, 혹시 모르니 VSCode를 껐다가 다시 실행한다.

 

 

설치는 모두 끝.

프로젝트를 만들고 테스트 하는 건 다음 포스팅으로...